Cloud 11 - Issues with call delivery to UK numbers and affecting PCI payments
Incident Report for NewVoiceMedia - A Vonage Company
Resolved
This incident has been resolved. If you believe you are still affected by this issue, please don't hesitate to contact our Customer Support team via your usual contact methods.
Posted Feb 13, 2020 - 10:51 GMT
Update
We are continuing to monitor for any further issues.
Posted Feb 01, 2020 - 18:01 GMT
Update
We are continuing to monitor for any further issues.
Posted Feb 01, 2020 - 18:01 GMT
Monitoring
We believe the issue to be remediated and the service should be restored. If you believe you are still affected by this issue, please don't hesitate to contact our Customer Support team via your usual contact methods.

Our Incident Management team will now continue to investigate the root cause and further updates will be provided shortly.
Posted Jan 31, 2020 - 19:36 GMT
Investigating
We are currently experiencing an issue with calls not being delivered to some UK numbers and affecting PCI payments in EMEA region. Our Incident Management are working on resolving the issue as a matter of urgency.
If you believe you are still affected by this issue, please don't hesitate to contact our Customer Support team via your usual contact methods.
Posted Jan 31, 2020 - 16:27 GMT
This incident affected: Cloud 11 - UK & Europe (Inbound Voice Interactions, Outbound Voice Interactions, PCI Payments).